Adverti horiz upsell

LarmorVoronoi Plugin for Maya 2012-2013-2014 1.1.1 for Maya (maya plugin)

LarmorVoronoi is a Voronoi Shatter Plug-in in C++ for Maya

License
Button download
5,096 Downloads

Compatibility

  • 2014, 2013, 2012

Operating Systems

  • Linux
  • Mac
  • Windows

History

Created:09/08/2013
Last Modified:03/08/2014
File Size: 17.6 MB

Keywords

voronoi, maya

Bugs

Corruption of System PATH during installation

Statusclosed
Prioritymedium
Date01/11/2014
Submitted bykanenas kanenas
Latest version 1.1.0 build 77 installed on Win7 SP1 Ultimate.It claimed the PATH was empty and added itself.Just the plugin now in the System PATH. The User PATH is still intact.It is possible my PATH was close to its length limit and that caused the problem.Nevertheless, either cover for it, or much better, do NOT add anything to the path. Append to Maya.env or make a note for the user to handle it.

Comments on this bug:

  • Pier Paolo Ciarravano

    Pier Paolo Ciarravano said about 8 years ago:

    Hi and thanks for your bug report. the first time when you installed the plugin, you should have had some errors into the installer log window. Have you maybe copied this log messages, so I can understand better what was going wrong? Without these log messages I can only guess the issue. Anyway the plugin installer uses the stable and popular installer NSIS (Nullsoft Scriptable Install System) and the NSIS component https://nsis.sourceforge.net/Environmental_Variables:_append,_prepend,_and_remove_entries in order to update the environment variable PATH. I can see that there was found a bug on this installer component and I can see on NSIS site the message added just yesterday: "WARNING: Strings longer than ${NSIS_MAX_STRLEN} will get truncated/corrupted. Do NOT use this function to update %PATH%". I will change the installer behaviour avoiding the use of this installer component in the next version of the plugin (just today), providing also a manual install method. Unfortunately, since the plugin is using some shared dynamic libraries, the only way for Maya to load this libraries is changing the PATH environment variable, since you don't want to copy the required .dll into the Maya bin directory, this is the link that effectively explain this: https://docs.autodesk.com/MAYAUL/2014/ENU/Maya-API-Documentation/files/GUID-E7B113F2-5AFD-4C05-A747-298C06586447.htm (the maya.env doesn't work for the shared dynamic libraries). Thank you very much Pier Paolo
  • Pier Paolo Ciarravano

    Pier Paolo Ciarravano said about 8 years ago:

    The bug has been fixed with a new Windows installer version. Thanks Pier Paolo
  • kanenas

    kanenas said about 8 years ago:

    Verified. The plugin is installing properly. Thank you much for taking care of this.

Post a comment: