Adverti horiz upsell

AdvancedSkeleton 3.9.9 for Maya (maya script)

AdvancedSkeleton is a collection of Maya tools for doing character setup

License
Button download
125,164 Downloads

Compatibility

  • 2011, 2010, 9.x, 2009, 2008, 8.x

Operating Systems

  • Linux
  • Mac
  • Windows

History

Created:09/26/2000
Last Modified:01/03/2017
File Size: 28.3 KB

Bugs

Troubles with Mac, no big suprise.

Statuspending
Prioritylow
Date05/17/2011
Submitted byJoel Anderson Joel Anderson
Is there anyone out there using this on the Mac?

I did the manual install so the shelf appears and all the buttons are there. But, non of the .iff or.png images are found, so using the biped selector is all grey.
Also I tried to load an animation via the Pose designer and I get this error message

// Error: Invalid negative index used to reference array "$tempString".
I am usually a pc user, but I am stuck on a mac.

Comments on this bug:

  • j stroy

    j stroy said about 11 years ago:

    THE FIX!!! To get the PoseDesigner and Selector to work more correctly, showing the images and save and load poses on maya 2011 or newer on the mac, the AdvancedSkeleton 3.7 scripts need to be patched. The icon image location is used by the scripts to find the associated data files.. so if the icon location is broken, the whole thing won't work and you get a negative index $tempString error. The patch is to fix the way it chooses image file extensions.. there is logic that checks maya version number and THEN if it is running on a mac. These IF statements need to be in the OPPOSITE order, meaning check if mac, and then check if maya 2011 or newer: Do a multi-file search of the AdvancedSkeleton scripts & subdirectories with something like TextWrangler for "iff" to find this bug in several locations in the AdvancedSkeleton scripts. change the logic by cutting the 2 lines of "if (about -mac) ..." and pasting it before the if (>=2011). Because for may 2011 and newer (regardless of the platform) .PNG is the correct file format to use for both the icons and the 32bit BGicons. Hopefully this is fixed in future versions beyond 3.7
  • Joel Anderson

    Joel Anderson said almost 11 years ago:

    Could not get it to work, Thanks anyways. Hope they fix it after 3.7

Post a comment: