Adverti horiz upsell

as_polyFracture 0.5.8 for Maya (maya script)

polygonal shatter based on 3D voronoi algorithm

License
Button download
9,613 Downloads

Compatibility

  • 2018, 2017, 2010, 2009

Operating Systems

  • Irix
  • Linux
  • Mac
  • Solaris
  • Windows

History

Created:03/10/2010
Last Modified:05/23/2019
File Size: 28.7 KB

Keywords

fracture, voronoi

Q/A

Maya 2015 Support

Date:06/30/2014
Submitted by: ohfrisky ohfrisky
This is a pretty awesome little script that does what the Maya shatter tools don't, I love it.
I have it working great on Maya 2014, but it doesn't seem to run in Maya 2015.
Are you planning on supporting this script for Maya 2015? I hope you do.

The issue is that when I try to perform step 2 I get the following error:
# Error: NotImplementedError: file S:\Maya_2015_DI\build\Release\runTime\Python\Lib\site-packages\maya\OpenMaya.py line 4019: Wrong number or type of arguments for overloaded function 'new_MFloatVector'. 
Possible C/C++ prototypes are:   
MFloatVector()   
MFloatVector(MFloatPoint const &)   
MFloatVector(MFloatVector const &)   
MFloatVector(MVector const &)   
MFloatVector(MPoint const &)   
MFloatVector(float,float,float)   
MFloatVector(float const [3]) #  

I think the issue is that you don't have Maya 2015 in line 292 as a version that can create the locators. 

Post a reply: