Adverti horiz upsell

Auto Pipe 0.3.6 for Maya (maya script)

Quickly create pipes along curves that can be animated

License
$20.00
(qty: 1)

  • Check 16 Future Updates Included
  • Check 16 Highend3d Quality Checked
  • Check 16 Purchase Guarantee
  • Check 16 Support Included

Compatibility

  • 2019, 2018, 2017, 2016, 2015, 2014, 2013, 2012

Operating Systems

  • Mac
  • Windows

History

Created:09/29/2013
Last Modified:03/12/2019
File Size: 19.4 KB

Keywords

maya

Q/A

# Error: TypeError:

Date:11/10/2013
Submitted by: Richard Frieser Richard Frieser
Hi,
I've followed all readme instructions..... but when I load the python scrript I receive this: # Error: TypeError: file C:/Users/Richard/Documents/maya/2013-x64/prefs/scripts\svAutoPipe.py line 126: Invalid flag 'fla' # ...
I'm using Maya 2013....... any suggestions.....???????????
cheers...hope I can get this to work
 .......................................

script:::::::::::::::::
import svAutoPipe as svAutoPipesvAutoPipe.autoPipes()# Error: TypeError: file C:/Users/Richard/Documents/maya/2013-x64/prefs/scripts\svAutoPipe.py line 126: Invalid flag 'fla' # curve -bezier -d 3 -p -94.420713 0 -39.683711 -p -94.420713 0 -39.683711 -p -54.304605 0 -39.903333 -p -40.773466 0 -33.205593 -p -27.242326 0 -26.507854 -p -15.563525 0 -11.922089 -p 10.712448 0 -5.349884 -p 36.988421 0 1.222322 -p 41.835552 0 2.18449 -p 61.540511 0 -10.922447 -p 81.245471 0 -24.029383 -p 74.754181 0 -40.048063 -p 95.403945 0 -28.862915 -p 116.053709 0 -17.677767 -p 120.929262 0 -23.403777 -p 125.470109 0 -5.670699 -p 130.010956 0 12.062379 -p 121.780942 0 33.329248 -p 101.496382 0 37.580722 -p 81.211821 0 41.832196 -p 71.225829 0 33.191344 -p 55.280387 0 47.12834 -p 39.334945 0 61.065335 -p 55.269523 0 69.502998 -p 22.861059 0 71.933478 -p -9.547404 0 74.363959 -p -2.149816 0 88.593782 -p -34.71232 0 62.595268 -p -67.274824 0 36.596754 -p -77.810146 0 19.004499 -p -97.013388 0 19.390121 -k 0 -k 0 -k 0 -k 1 -k 1 -k 1 -k 2 -k 2 -k 2 -k 3 -k 3 -k 3 -k 4 -k 4 -k 4 -k 5 -k 5 -k 5 -k 6 -k 6 -k 6 -k 7 -k 7 -k 7 -k 8 -k 8 -k 8 -k 9 -k 9 -k 9 -k 10 -k 10 -k 10 ;// Result: bezier1 // import svAutoPipe as svAutoPipesvAutoPipe.autoPipes()# Error: TypeError: file C:/Users/Richard/Documents/maya/2013-x64/prefs/scripts\svAutoPipe.py line 126: Invalid flag 'fla' #  

Replies to this question:

  • ktplive

    ktplive said over 10 years ago:

    Hi Richard Just tried it in 2011 and got the same issue - I must have added the fla flag in a recent update which mustn't be supported in pre-2013.5 versions - purely a visual display flag for the interface. Thrown in a line of error correction which should hopefully do the trick for you. Should be a new version uploaded ready for downloading. Cheers
  • Replyindent
    Richard Frieser

    Richard Frieser said over 10 years ago:

    great stuff! all working.... thank's ...
  • Replyindent
    ktplive

    ktplive said over 10 years ago:

    Well, installed 2013 to check things out and had 3 different results from 2011/2013/2014 - seems 2011-2013 treat a space in the ui in a slightly different manner - where a space was being treated as a tab hence pushing the ui off to the side - 2011 would auto resize the entire window so it wasn't so much of an issue other then the interface looking a little untidy however with 2013 as you notice it would crop it. Reworked the issue at hand to be uniform across the versions with the exception of the fla flag which creates more of a bevel look for 2014 users. In short - should all be working as expected now.
  • Replyindent
    Richard Frieser

    Richard Frieser said over 10 years ago:

    Also thank you for your super fast response to the last issue.....
  • Replyindent
    Richard Frieser

    Richard Frieser said over 10 years ago:

    little bit of a ui issue...I don't seem to be able to see or use the Scale:y....subd: u ....Fields

Post a reply: