Adverti horiz upsell

Ctrl O 2.3.1 for Maya (maya script)

Tool to build your controllers faster, with a little viewport to preview the controllers, customizable controllers-shapes bank, mirroring abilities

Button download


  • 2017, 2016, 2015, 2014, 2013

Operating Systems

  • Irix
  • Linux
  • Mac
  • Solaris
  • Windows


Last Modified:10/19/2017
File Size: 29.7 KB


Inatsllation Error

Submitted by: Grayalzz Grayalzz
I followed the instruction:
- Unzip the zip file in C:\Users\Grayalzz\Documents\maya\scripts
- Then I typed  the following script in my Python script tab in Maya :
import sys
import Ctrl_O
And when I executed the script, I got this message :
# Error: line 1: AttributeError: file <maya console> line 4: 'module' object has no attribute 'Display_CtrlO_UI' #
I don't know where I went wrong, can you help me please >"<

Replies to this question:

  • mlouala

    mlouala said over 5 years ago:

    Hi Grayalzz,
    Try to type sys.path.append(r'C:\Users\Grayalzz\Documents\maya\scripts\Ctrl_O') 
    if your script is located inside a folder, if the folder have the name Ctrl_O try to change it to something else (to avoid confusion for Maya)
    Sorry for late answer ^^,
    Have a nice day,
  • Replyindent

    arcticfoxpi said over 5 years ago:

    Doing the \\ thing worked for me. Thanks!
  • Replyindent
    Pang Ren Tan

    Pang Ren Tan said over 5 years ago:

    under the string for your file location. use double slashes "\\" or "/" for each folder so. 

    'C:\Users\Grayalzz\Documents\maya\scripts\Ctrl_O' should be 


    Should work because i had the same error and this pretty much made it work. 
  • Replyindent

    tristratos said over 5 years ago:

    I also tried to install it, similarly as Grayalzz described, but this fails to load providing always the same error:
    # Error: line 1: AttributeError: file <maya console> line 4: 'module' object has no attribute 'Display_CtrlO_UI' #
    I tried to change the folders names, but that insists to NOT load at all!!
  • tristratos

    tristratos said over 5 years ago:

    @ Mehdi Louala
    PLEASE fix your script. 
    As is, it seems impossible to be installed/loaded and therefore unable to be used!
    PLEASE keep us posted

Post a reply: