Adverti horiz upsell

Graph Editor Redux, Digital Pose Test, MayaStylin' 3.0.0 for Maya (maya script)

cgJedi Animation Suite

License
Button download
13,998 Downloads

Compatibility

  • 2018, 2017, 2016, 2015, 2014, 2013, 2012

Operating Systems

  • Linux
  • Mac
  • Windows

History

Created:04/22/2008
Last Modified:08/27/2017
File Size: 11.9 MB

Bugs

Should this work on Mac?

Statuspending
Priorityhigh
Date09/16/2010
Submitted byswatch swatch
Hello!

I was excited to try-out this very interesting plug-in, but it seems as though it's not functioning properly on Mac.  Actually, it's not functioning at all!  Maya crashes when I load it, then invoke the graph editor.  I'll start with describing my method to install and all the errors that are spit out by Maya:

1/ Extracted archive
2/ Copied GER folder to my /Users/Shared/Autodesk/maya/2011/plug-ins folder
3/ Loaded Maya
4/ Went to Window > Settings/Prefs > Plug-In Manager
5/ Browsed for and then loaded the rb_GraphEditorReduxPlugin.py from the above-mentioned folder
6/ Turned on Auto-Load
7/ typed-in GER -load; as a MEL command
8/ received this error:

GER -load;

// Warning: New procedure definition for "updateGraphEdSelectMenu" has a different argument list and/or return type. //

// Warning: New procedure definition for "buildGraphEdSelectMenu" has a different argument list and/or return type. //

GER: Loaded /Users/Shared/Autodesk/maya/2011/plug-ins/GER/scripts/graphEditorPanel.mel

GER: Loaded rb_gerPlugins.py

9/ Scratched head and then animated a ball and tried to open Graph Editor
10/ Another error popped up:
 
// Error: displayString identifier "m_graphEditorPanel.kDecreaseOutliner" does not exist. // 

11/ Clicked on the only button visible on the Graph Editor (the icon looks like a light blue lattice hull with "STATS" in front of it)
12/ Maya freezes/hangs/crashes

I am running Maya 2011 x64 on Mac OS X.  OS X version 10.6.4 on MacBook Pro 15" i7 2.66 Quad Core, 8 GB RAM.

I would absolutely love to run this on my machine.  Thanks for any help! 

Comments on this bug:

  • spike1201

    spike1201 said over 11 years ago:

    Yes, it works on Snow Leopard, but I don't know about 2011. I have Maya 2009. I hope you find a way--it's super helpful for animation efficiency! Good luck. Spike
  • spike1201

    spike1201 said over 11 years ago:

    By the way, I'm not expert in this, but I couldn't get MEL to successfully launch this plug-in either. I used the Python instructions instead (from the Read-Me.txt). Hope this helps.
  • johnyz

    johnyz said about 11 years ago:

    Dude it works perfectly on Mac. I had the same problem! The deal is - u need to copy it to your folder: /Users/Shared/Autodesk/maya/2011/plug-ins/plug-ins not /Users/Shared/Autodesk/maya/2011/plug-ins/ So do it and check it out! Hope that helps! DOOOOOOOOOOOOOOOOOD!!!!!!! Helped me!
  • johnyz

    johnyz said about 11 years ago:

    Sorry maybe I was not clear: Copy the whole GER directory into: /Users/Shared/Autodesk/maya/2011/plug-ins/ and then also copy GER/plug-ins/ into /Users/Shared/Autodesk/maya/2011/plug-ins/ Its just that both those files needs to be loaded in your maya plug-in manager for it to work i think: rb_GraphEditorReduxPlugin.py rb_gerPlugins.py
  • frasu

    frasu said almost 10 years ago:

    Does anybody else has problems loading this for 2013 on a Mac? I am not able to find a proper way to instal the needed PyQt4 so I am getting an error " RuntimeError: sip can not be found. This is part of PyQt4" Any help or links would be appreciated.
  • Carlo Sansonetti

    Carlo Sansonetti said over 9 years ago:

    I get the same issue as frasu, but on Windows. I noticed that GER works if I run it first, but if I run any of my custom PyQt UIs first and then start GER, it stops working giving me the same error "RunTimeError: sip can not be found. This is part of Pyqt. Obviously I have sip on my system because I use it in my UI development. Any ideas? I am using Maya 2013x64 on Windows 7 64 bit Pyqt version (downloaded from Nathan Horne's website: https://dl.dropbox.com/u/1633130/PyQt%20x64/Maya%202013/pyqt_4.9_qt_maya.zip Please help! I need this for work. I ran out of ideas. Thanks.
  • 66ahri

    66ahri said over 9 years ago:

    it seems that you've to go by yourself since there's not a compiled version of these libraries for mac osx…i'm trying to go with these instructions i found on the web: https://www.noktec.be/python/how-to-install-pyqt4-on-osx Any help from mac users working on maya 2013 who were able to make this plugin run on their snow leopard machines would be really appreciated!

Post a comment: