Adverti horiz upsell

Graph Editor Redux, Digital Pose Test, MayaStylin' 3.0.0 for Maya (maya script)

cgJedi Animation Suite

License
Button download
13,997 Downloads

Compatibility

  • 2018, 2017, 2016, 2015, 2014, 2013, 2012

Operating Systems

  • Linux
  • Mac
  • Windows

History

Created:04/22/2008
Last Modified:08/27/2017
File Size: 11.9 MB

Bugs

rawFrameNumber error

Statusclosed
Prioritylow
Date04/22/2013
Submitted byRussell Dumornay Russell Dumornay
following is reported in script editor when attempting to create poses and playbacks.

// Error: -rawFrameNumber option must be used with at least one -frame flag, ignoring -rawFrameNumber. // 
# Traceback (most recent call last):
#   File "c:\MyData\Programming\My_3D\MayaScripts\grapheditorredux\GER_2013\scripts\rb_DPT.py", line 2364, in doGetRangeFromMaya
#   File "c:\MyData\Programming\My_3D\MayaScripts\grapheditorredux\GER_2013\scripts\rb_DPT.py", line 2317, in getPoses
# TypeError: Object [] is invalid

Comments on this bug:

  • rbublitz

    rbublitz said about 9 years ago:

    Do you actually have keyframes on the objects you have selected?
  • Russell Dumornay

    Russell Dumornay said about 9 years ago:

    Yes. We tried it with an unrigged sphere and sphere rigged with a lattice and it works fine. Once we tried DPT with our custom rigs it fails to create poses and playblasts. Besides the stacktrace is there anything else you need that may help resolve this? Thanks, Russell
  • Russell Dumornay

    Russell Dumornay said about 9 years ago:

    Hi do you have any updates regarding this? If its any consolation Jeff Schu sends his greetings
  • rbublitz

    rbublitz said about 9 years ago:

    I've been focused on converting the tools to work with Maya2014. I hope to release an update shortly.
  • rbublitz

    rbublitz said about 9 years ago:

    I released a new version with a better check. It will error out if there are no keys within the timeline range you have selected. Now this might or might not fix the issue you are having with your rigs. The one thing I thought to ask is if you are using animation layers? Since this is a python plugin and uses Maya's API, animation layers are not supported.

Post a comment: