Adverti horiz upsell

Goblin animation import/export 6.3.6 for Maya (maya script)

handle animLayers and constrained objects

License
Button download
2,652 Downloads

Compatibility

  • 2016, 2015, 2014

Operating Systems

  • Linux
  • Mac
  • Windows

History

Created:12/03/2011
Last Modified:12/27/2016
File Size: 200 KB

Keywords

animation, animLayer

Bugs

error on import

Statusclosed
Prioritylow
Date03/21/2012
Submitted byrbublitz rbublitz

# Error: line 1: invalid literal for float(): 2011P01

# Traceback (most recent call last):

# File "<maya console>", line 1, in <module>

# File "D:/python/scripts/Goblin\goblin.py", line 41, in <module>

# ValueError: invalid literal for float(): 2011P01 #

 

Unfortunately I get the above error which importing.  This is Linux and Maya 2011.

Comments on this bug:

  • Stepan Koncelik

    Stepan Koncelik said over 10 years ago:

    should be fixed in current release
  • rbublitz

    rbublitz said over 10 years ago:

    So, yes, it now imports. However, changing to Advanced GUI crashes Maya.
  • canavar

    canavar said over 7 years ago:

    Sorry for noob question :) when i use import Goblin Goblin.show() maya says # Error: ImportError: file line 1: No module named Goblin # what am i doing wrong? thanks
  • Stepan Koncelik

    Stepan Koncelik said over 7 years ago:

    Hi, your Goblin is probably under location, which is not part of PYTHONPATH. Try run this script under python section of Script Editor: import sys for item in sys.path: print item it will write down all location recognized as importable destinations for python. If you want to add your own specified destination, write in userSetup.py something like: import sys sys.path.append( "myScriptLocation" ) hope this helps

Post a comment: