Adverti horiz upsell

Nightshade UV Editor 2.1.3 for Maya (maya script)

Nightshade UV Editor extends the Maya's UV Texture Editor with tools, scripts and a UI that greatly speed up the time it takes doing UV work.

Button download


  • 2017, 2016, 2015, 2014, 2013

Operating Systems

  • Mac
  • Windows


Last Modified:09/11/2016
File Size: 3.2 MB


Is this a client side issue or a bug?

Submitted by: Panicintrinsica Panicintrinsica
Anytime I try to open NSUV after I've opened up a scene, I get the following error:
# Error: TypeError: file D:\Applications\Autodesk\Maya2016\Python\lib\site-packages\pymel\core\ line 963: unsupported operand type(s) for +=: 'NoneType' and 'NoneType' 
For reference, the line in question (963 of reads as follows:

listReferences.__doc__ += iterReferences.__doc__

I've gotten this same error in three different versions of NSUV and two versions of Maya, but since I can't find anyone else even mentioning it, I'm not going to 100% rule out that it's a weird one-off. It opens and operates just fine provided I import before I open any scenes, but once a scene is open, if I did not already have the UV window open in the background, I have to save and reset in order to open it. I was hoping that a new release would fix it, but I just tried it with 2.0.10 and it's still there for me.

(Using 2016 SP5 on Windows 10)


Replies to this question:

  • Martin Dahlin

    Martin Dahlin said over 6 years ago:

    Hello. This could be an issue with the PyMEL files that come bundled with Maya. Try this: Instead of starting up NSUV, run the following code in the Python tab: import pymel.core as pm If this generates the same problem, then the issue is with Maya and not NSUV. Try reinstalling and/or contact the Autodesk support. You can also try skipping the latest service pack and instead go with an earlier one.
  • Replyindent
    Martin Dahlin

    Martin Dahlin said over 6 years ago:

    Wow, that's really interesting. I don't think I would've ever considered that to be the cause of the problem. After all, all that Maya does with the PyMEL module is to read the files off the harddrive (nothing is written afaik). Maybe this is related to the compiled python files (pyc) in the user script dir not being generated due to said windows privileges (Windows generally don't like modifications to anything under C - unless we are talking the user folders). Either way: thanks for sharing this. Hopefully others with the same problem will see this solution - and if they don't then I'll remember this. Also: thanks for the kind words :) Knowing that NSUV helps people reduce their pain and save time is what keeps me going.
  • Replyindent

    Panicintrinsica said over 6 years ago:

    I actually just figured this out about 10min ago. I installed and started having issues with Quxiel’s Color ID script for Maya, which is only other plugin I’ve had issues with to date. Well, turned out the reason that script was not opening was a privileges issues with Windows, and as soon as I fixed that, the error with NSUV also went away. So it was 100% client side. So, the lesson here is to make absolutely 100% sure Maya has admin privileges. Also, has a note, thank you for making and supporting this plugin, it’s made UVing infinitely more bearable for me!

Post a reply: