Adverti horiz upsell

PAIE 1.3.3 for Maya (maya script)

Animation / Pose library tool.

License
Button download
6,219 Downloads

Compatibility

  • 2018, 2017, 2016, 2015, 2014

Operating Systems

  • Linux
  • Mac
  • Windows

History

Created:03/27/2008
Last Modified:10/18/2018
File Size: 69.7 KB

Keywords

Pose, animation

Q/A

paie not loading on mac

Date:08/01/2010
Submitted by: thecaravel thecaravel
Your tool sounds really cool but I can't import it in the python script editor.
When "import paye" I just get this reply:
# Error: No module named paie

I saved the paie.py in this path:
./Applications/Autodesk/maya2009/devkit/devkit/phthonScripts/

Also tried it in here:
/Applications/Autodesk/maya2009/devkit/devkit/application/scripted/
/Applications/Autodesk/maya2009/devkit/devkit/other/PyQtScripts/

Nada. It can't find it.

I thought of forcing a path with PYTHONPATH in a terminal (as suggested) but:
PYTHONPATH: Command not found.

Sorry, I'm not a wizard when it comes to this kind of system stuff.
If there is a kind soul who has seen this before and is willing to share his knowledge, I'd be sooo thankful.

 

Replies to this question:

  • Replyindent
    Jakob Welner

    Jakob Welner said over 11 years ago:

    Hey there and sorry for the late reply. Have been too busy and forgetting about this tool. I'm no wizard with Mac either and it seems like you have tried a lot of different possibilities. However, one way that should be fairly certain is to open the script editor in python mode and type: import sys; print sys.path That should give you a list of all the paths where Maya looks for python modules, so if you put paie.py in either of them and restart Maya, it should be there and no longer complain about module not found when you, in a python commandLine, type: import paie Give it a go and tell me what's happening.. provided you haven't gotten it working since you wrote here and that you're still keen to try it. Cheers - Jakob
  • guwaijeun

    guwaijeun said almost 11 years ago:

    I was also having this issue on Maya 2012 on Mac. I had tried to put paie.py in all of the common "scripts" folders I could find, but it still gave me the "# Error: No module named paie" error. After trying "import sys; print sys.path", I was able to locate a path to put the script in. After restarting Maya, the script loaded fine. Thanks!
  • j stroy

    j stroy said over 10 years ago:

    Had an error message about "splitlist" being reference without being defined. To make it work, I had to add this at line 1948: splitList = filePath.split('/') This is because of the platform logic not having a default value for splitlist. Had no problem getting it to load. I put it in Users/username/Library/Preferences/Autodesk/maya/scripts

Post a reply: