Adverti horiz upsell

PM_heatWeight 0.6.6 for Maya (maya script)

Better default/auto weighting to a skeleton!

License
Button download
12,863 Downloads

Compatibility

  • 2010, 2009, 2008, 8.x

Operating Systems

  • Linux
  • Mac
  • Windows

History

Created:05/16/2009
Last Modified:03/31/2010
File Size: 623 KB

Q/A

[Errno 13] permission denied

Date:03/04/2010
Submitted by: sheriffcicada sheriffcicada

Hey there-

Has anyone gotten this error:

# Warning: encountered exception while weighting mesh |polySurface14|polySurfaceShape14:

[Errno 13] Permission denied #

I was just trying a test, but got this instead. The skin was still bound, but not the results I expected.
Any ideas? 

 

Replies to this question:

  • John Neumann

    John Neumann said about 12 years ago:

    Yes I continuously have gotten that error. I hadn't noticed that it bound the skin, but it's still giving me that error no matter what I do. At first I thought it was because my geo's attributes were locked, but after messing with it, it doesn't seem to have made a difference.
  • barnabas79

    barnabas79 said about 12 years ago:

    Pneumonic, what os are you using?
  • John Neumann

    John Neumann said about 12 years ago:

    Sorry for such a long wait on a response. I had hoped it would notify me when a response was posted. I'm running it on Mac OS. I was using Leopard(10.5.8), but am now on Snow Leopard (10.6.2) and still have the same issues. I'll continue checking here since there's no subscribe option that I can see (or I may just be blind :).
  • artifish

    artifish said about 12 years ago:

    heya, just ran into the same problem on linux, turns out that the executable binary file "AttachWeights..." was not "executable". Not sure about osx, but you should be able to change the properties either through the finder or in the shell using the "chmod" command.
  • John Neumann

    John Neumann said about 12 years ago:

    AHHHHH!!! I'll give that a shot right now! I can't believe I didn't check that! I'll post back and let you know if that's the issue or not! [edit] That indeed was the issue! I can't believe I didn't check that. Also to note, if you just make the AttachWeightsMac executable without making both the PM_heatweight.py and .pyc executable it'll go into an endless loop of nothingness making you force quit the app. For those who don't know how to make things executable in OSX, open the terminal app (in Utilities) and type cd ~/Library/preferences/Autodesk/maya/{maya-version-number}/scripts replacing {maya-version-number} with your version of maya (ie. 8.5, 2009, 2010, 2011, whatever. if you're unsure, type ls into the command prompt after you cd into the maya directory and it should output what folders are there.) Then in the command up to then type in the following: #Use this version if you've already run heatWeight chmod +x AttachWeightsMac; chmod +x PM_heatWeight.py; chmod +x PM_heatWeight.pyc; # Use this version if you have not chmod +x AttachWeightsMac; chmod +x PM_heatWeight.py; That'll do it for ya! Thanks for the heads up artifish! Really appreciate it. Feel like a noob that I didn't bother checking that. [/edit]
  • barnabas79

    barnabas79 said about 12 years ago:

    Heh, you're not the only one who feels dumb. The files are properly marked as executable in the repo, so it seems the problem is that I created the zip file from a PC. I may need to end up making one archive per OS to make sure things are kosher... Regardless, though, I have a bit of a problem - at the moment, I don't have access to a Linux or Mac computer I can zip these up from. I was using my work computer, but they recently tightened up security there, and I can no longer upload / email files to myself from there. Do you think one of you mac or linux folks could try making a zip, with the required files marked as executable, and sending it to me so I can post it here? Thanks!
  • John Neumann

    John Neumann said almost 12 years ago:

    I just saw this posted so I'm emailing you a version with the executables for both as executable (that sounded redundant). I really wish creativecrash had a subscribe to thread feature. :/ Regardless. It'll be in the email as soon as this is done being posted. :)
  • John Neumann

    John Neumann said almost 12 years ago:

    Just tried the email address listed and it got shot back. Throw me an email on here: https://animateshmanimate.com/email/ and I'll shoot you the zip. :)
  • wingsofaggression

    wingsofaggression said almost 12 years ago:

    THANK YOU SO MUCH FOR THIS!!!
  • John Neumann

    John Neumann said over 11 years ago:

    Hey I emailed you the files and it didn't get bounced back this time. :) Let me know if there are any issues or if I can be of any more help. :)
  • css_maya

    css_maya said over 11 years ago:

    Hi barnabas if you try Oracle VM Virtual box and if you have different OS cd images, you can have as many OS as you want on your personal computer, you just need good hard space for them maybe this can help you develop faster
  • rakesh nanda

    rakesh nanda said over 11 years ago:

    Hi... I get the same error sometimes on my pc . A warning.. not an error. And in such cases is binds the skin but the wiegts are messed up . As I can see many others have the same prob too. Any solutions? Its a fantastic tool when it works but in my case it does so 60 percent of the time .. rest 0 percent i get this warning.

Post a reply: