Adverti horiz upsell

"Rapid Rig: Advanced" - Auto Rig 2.3.8 for Maya (maya script)

This is a tool that will set up a customizable rig for a bipedal character

License
$49.00
(qty: 1)

  • Check 16 Future Updates Included
  • Check 16 Highend3d Quality Checked
  • Check 16 Purchase Guarantee
  • Check 16 Support Included

Compatibility

  • 2019, 2018, 2017, 2016, 2015, 2014, 2013, 2012, 2011, 2010, 9.x, 2009, 2008

Operating Systems

  • Linux
  • Mac
  • Windows

History

Created:12/20/2009
Last Modified:03/13/2019
File Size: 151 KB

Keywords

maya, Rig, fk, autorig, auto-rig

Bugs

installation problem

Statusclosed
Priorityhigh
Date01/14/2013
Submitted byloopon . loopon .

hi!

i bought rapid rig and rapid pose and i would like to install them both.
(i use maya 2010 64 bit under pc, windows 7 ultimate 64 bit).

first try:
i installed the rapid rig - data in this folder
"C:/Users/YourUser/Documents/maya/scripts/ ".
i launched maya.
i opened in maya the script editor and typed in under the mel-tab:
"RapidRig_Advanced_V2"
i highlighted it and pressed return....

nothing is happening.

second try:
i installed the rapid rig - data in this folder
"C:/Users/YourUser/Documents/maya/2010-x64/scripts/ "
(this is the place, where my oher plugs are placed in folders).

i launched maya.
i opened in maya the script editor and typed in under the mel-tab:
"RapidRig_Advanced_V2"
i highlighted it and pressed return....

nothing is happening again.

can you please tell me: where is my mistake?

thanks for your answer!

regards
loopon

Comments on this bug:

  • Dustin Nelson

    Dustin Nelson said almost 9 years ago:

    If that path doesn't work, you can use the following command in your script editor to find the directory that Maya is looking for the script: //Start internalVar -usd; //End This should spit out the directory in your script editor. Are you getting an error or any other feedback when you hit enter? Do you get an error or anything? Dustin
  • loopon .

    loopon . said almost 9 years ago:

    hi dustin, thanks for your fast reply! "C:/Users/YourUser/Documents/maya/2010-x64/scripts/ " is the right directory, (and it workes well for other mel-scripts). when i highlight "RapidRig_Advanced_V2" in the script editor and press enter on the keyboard, maya gives me : //Error:Cannot find procedure "RapidRig_Advanced_V2" greetz loopon ps. the "RapidRig_Advanced_V2" - file has 1.106 KB unzipped and the RapidRig_Anim_V2"-file has 137 KB unzipped (is this correct, or maybe the files can be corrupted?)
  • Dustin Nelson

    Dustin Nelson said almost 9 years ago:

    The file sizes are correct. Are you hitting enter on the above the shift key or the enter key on the number pad? Try the number pad, it should work from there. Here are a couple other options if that doesn't work... 1. To make sure the script works, in the script editor, go under File>Source Script... Then navigate to RapidRig_Advanced_V2.mel and select it, then open it. This should bring up the interface. 2. If that works, then there is something strange going on with either the file path or something else that I am unsure of. Try typing RapidRig_Advanced_V2 into the Command Line (the bottom left text field of your Maya UI). 3. If you are able to get it to run from there, then the script editor is not doing what it should be. At this point, you may want to type RapidRig_Advanced_V2 into the script editor, then drag it to your shelf and see if that works. Let me know if any of this is successful. Dustin
  • loopon .

    loopon . said almost 9 years ago:

    hi dustin, with this way i got RapidRig_Advanced_V2 to my new shelf :-) GREAT! ------------------------------------------------------------------------------------------------------- but when i try to do the same with RapidRig_Anim_V2 there is an error: //Error: Too many children in layout: RRAnim_PoseLayout // ------------------------------------------------------------------------------------------------------- and when i try it with RapidRig_Poser_V2 (via source script) maya creates an interface called "Create Custom UI" in the maya window but this is not shown in the script editor, so that i couldn´t remove this plug into my shelf... greetz from loopon
  • Dustin Nelson

    Dustin Nelson said almost 9 years ago:

    RapidRig_Poser_V2 is a separate file that does not come with Rapid Rig Advanced. You have to purchase it separately (if you want it). It is an add-on that animators can purchase if they have a desire for that type of UI to assist in animation. It is available here: https://www.creativecrash.com/maya/marketplace/scripts-plugins/animation/c/-rapid-rig-poser-for-maya--2 The issue you are having with the RapidRig_Anim_v2 has come up once before and so far I have not been able to determine the cause. I use a Mac and it works fine in 2013 but I will continue to see if I can figure that out. Dustin
  • loopon .

    loopon . said almost 9 years ago:

    hi dustin, i saw your scripts and i thougt: "thats it!". compatibility was also given (maya 2010 running on windows). i bought the whole package because i wanted to build up an good and stable production pipeline for my purposes... espacially the rapidRig_anim is very important for me (mirroring poses for walkcycles etc.). i bought the whole package, because i need to use all parts of it. but it seems, that it is not working completely on my system (maya 2010 running on windows)... dustin, what can we do now? loopon
  • Dustin Nelson

    Dustin Nelson said almost 9 years ago:

    Hi loopon, I am trying to figure out what exactly the issue could be with RapidRig_Anim. Can you do me a favour which would help me diagnose the problem? In the script editor, please go to the "History" tab and enable "Line numbers in errors". Once you have done that, source/run RapidRig_Anim and let me know what error you get. Hopefully this time it will tell you the line number that the error is occurring on which will be helpful to me. I hope I can get this resolved for you so that you can spend your time focusing on animation and not on getting the scripts to run. Thanks for your patience. Dustin
  • Dustin Nelson

    Dustin Nelson said almost 9 years ago:

    Also, could you forward me your email address? I would like to send you a file for you to test on your machine because I cannot reproduce it on my end. You can send your email to me in a private message, if you prefer. When you say you purchased the "whole package," do you mean you bought Rapid Rig Advanced (which comes with Rapid Rig Anim) as well as Rapid Rig Poser? Dustin
  • loopon .

    loopon . said almost 9 years ago:

    hi dustin, thanks for your reply! yes, i bought Rapid Rig Advanced (which comes with Rapid Rig Anim) as well as Rapid Rig Poser, because i need a stable pipeline for animation which is compatible to each component. mainly i´m modeling and animating (in the beginning). bere is my email: waushh@gmx.de thanks! loopon

Post a comment: