Adverti horiz upsell

"Rapid Rig: Advanced" - Auto Rig 2.3.8 for Maya (maya script)

This is a tool that will set up a customizable rig for a bipedal character

License
$49.00
(qty: 1)

  • Check 16 Future Updates Included
  • Check 16 Highend3d Quality Checked
  • Check 16 Purchase Guarantee
  • Check 16 Support Included

Compatibility

  • 2019, 2018, 2017, 2016, 2015, 2014, 2013, 2012, 2011, 2010, 9.x, 2009, 2008

Operating Systems

  • Linux
  • Mac
  • Windows

History

Created:12/20/2009
Last Modified:03/13/2019
File Size: 151 KB

Keywords

maya, Rig, fk, autorig, auto-rig

Q/A

Maya 2011 issues?

Date:02/05/2011
Submitted by: Anne O'Namus Anne O'Namus
First off, I love RapidRig.  Thank you so much Dustin.

I'm wondering if anyone else is having problems in Maya 2011.  The last time I was working with RapidRig was 1.3.x and it worked fine.  Recently I tried out 1.4.2 on 2011 and I found 2 problems:

1) model blows up after you skin it, save file, close maya, open maya and load that same file.  My model is not all one piece so things like the ears, feet, strokes were off the rig by a few feet (in relative space).  Solution:  I brought it into 2010 and it's fine. BUT...

2:) on both 2010 and 2011 I noticed the saved dummy rig is hit and miss when loading it.  Then if it misses it's messed for life.

I'm thinking it's Maya 2011 because it's just full of bugs and it's possibly the worst Maya since 8.0.  So, while RapidRig is freaking awesome, I'm having a few issues I thought I'd mention.

Using OSX 10.6.3 

Replies to this question:

  • Dustin Nelson

    Dustin Nelson said almost 11 years ago:

    Hi Anne, It's great to hear that you love the rig! Thank you for the detailed descriptions and the version #'s you experienced the problems in. It makes it much easier to diagnose the problem. I will admit, I do almost all of my tool building in Maya 2009 because 2011 is a steaming pile, in my opinion. I am also using the same OS as you, so I will have a look in 2010 and see what's going on. Hopefully I will have an answer for you soon, thanks! Dustin
  • Dave Challenger

    Dave Challenger said almost 11 years ago:

    Just to add from my own experince I also have this issue with the dummies (in 2011) but I rarely use the feature so I'm afarid I don't know more. On the positive side though it's easy enough to reposition the dummies but if you needed them to be exact it's not ideal, it also appears to shift the ball and toe dummies. The easiest work around I can think of is saving out a version of you're dummies laid out correctly so that if you ever did need to go back to them you could simply import the dummies from that backup .ma file (aslong as any auto rigger updates don't affect the older dummy setup.)
  • Dustin Nelson

    Dustin Nelson said almost 11 years ago:

    OK, did a bit of investigation. There was a bug on saving out the dummies with the knees, so I fixed that. The fix is in version 1.4.4. Thanks for pointing that out! Was there anything else that seemed to get buggered on loading poses? And if so, did resetting the poses get everything back to default, or were they still messed up? Also, Anne, I haven't been able to replicate the issue you are having with the geo blowing up. I used a model that I had that was in many pieces as well, and I didn't seem to get anything like what you described. One known issue in Maya is with the new Dual Quaternion option for skin clusters. This option can cause really weird issues with joints that scale. And this is not isolated to my rig, so hopefully this will be improved in the next release (which should be soon!). If you could provide me with further information on the model blowing up, that would be helpful. Here are some questions you could answer to help me out: -Was history deleted and transforms frozen on geometry? -Was your character in its default pose or in a different pose when you saved it? -Did you get any errors when you open the file? I think that's about all I have... Thanks! Dustin

Post a reply: