Adverti horiz upsell

"Rapid Rig: Poser" for Maya 2.0.9 for Maya (maya script)

A UI designed to enhance the animation pipeline of the "Rapid Rig: Advanced"

License
$20.00
(qty: 1)

  • Check 16 Future Updates Included
  • Check 16 Highend3d Quality Checked
  • Check 16 Purchase Guarantee
  • Check 16 Support Included

Compatibility

  • 2018, 2017, 2016, 2015, 2014, 2013, 2012, 2011, 2010, 9.x, 2009, 2008

Operating Systems

  • Mac
  • Windows

History

Created:10/28/2010
Last Modified:11/20/2017
File Size: 39.6 KB

Keywords

fk, select, Rig

Q/A

Saving & Loading Poses

Date:03/07/2011
Submitted by: K Y K Y
Hi all,

I'm curious if saving & loading poses apply only to the checked main control attributes in the save load tab? I was successful on saving & loading those values however not for the actual pose my character is making. I'm thinking that's not how it is right?? I really appreciate helps on this. I'm using maya 2011 with windows 7 64bit. Many thanks in advance!!

Replies to this question:

  • Replyindent
    K Y

    K Y said almost 12 years ago:

    Hi Dustin, Thanks for your immediate reply and great scripts! When I click Save Pose or Load Pose button it gives a warning saying "Command fielBrowserDialog has been deprecated. Use fileDialog2 instead. " Maya does not give this warning when I try to open the file browser dialog through say FIle>Save Scene As... from the Maya main menu. Is this something related? Thanks.
  • Replyindent
    Dustin Nelson

    Dustin Nelson said almost 12 years ago:

    [quote=k-y--2]Hi all,

    I'm curious if saving & loading poses apply only to the checked main control attributes in the save load tab? I was successful on saving & loading those values however not for the actual pose my character is making. I'm thinking that's not how it is right?? I really appreciate helps on this. I'm using maya 2011 with windows 7 64bit. Many thanks in advance!!
    [/quote] Hey, Saving and loading should work for the character's entire pose. Do you know if you were getting any errors when you were saving or loading the data? If so, let me know if and what they are, and I can try and figure out what might be the problem. Thanks! Dustin
  • Dustin Nelson

    Dustin Nelson said almost 12 years ago:

    That is something that has to do with code that has changed a bit from previous versions of Maya. I have been using the older MEL commands and I thought it worked OK in 2011, but I will have another look and see. I have been doing most of my updates in older versions of Maya just to make sure they are backwards compatible. If that is the issue, I will have to write in a bit of code that checks which version you are using. Thanks for the info, and I will let you know soon! Dustin
  • Dustin Nelson

    Dustin Nelson said almost 12 years ago:

    I just tried saving and loading in 2011 and everything seemed to load in ok. If you open the file that "Save Pose" writes out in text editor or notepad or something similar, there should be at least a couple hundred lines of code (depending on your rigged character), and it should look something like this: string $rigName[] = `ls -sl`; if (`objExists ($rigName[0]+ "_EyeAimC")`) {setAttr {$rigName[0]+ "_EyeAimC.tx"} 0;} if (`objExists ($rigName[0]+ "_EyeAimC")`) {setAttr {$rigName[0]+ "_EyeAimC.ty"} 0;} if (`objExists ($rigName[0]+ "_EyeAimC")`) {setAttr {$rigName[0]+ "_EyeAimC.tz"} 0;} if (`objExists ($rigName[0]+ "_HeadC")`) {setAttr {$rigName[0]+ "_HeadC.tx"} 0;} if (`objExists ($rigName[0]+ "_HeadC")`) {setAttr {$rigName[0]+ "_HeadC.ty"} 0;} if (`objExists ($rigName[0]+ "_HeadC")`) {setAttr {$rigName[0]+ "_HeadC.tz"} 0;} if (`objExists ($rigName[0]+ "_HeadC")`) {setAttr {$rigName[0]+ "_HeadC.rx"} -12.37226744;} if (`objExists ($rigName[0]+ "_HeadC")`) {setAttr {$rigName[0]+ "_HeadC.ry"} -5.244575531;} if (`objExists ($rigName[0]+ "_HeadC")`) {setAttr {$rigName[0]+ "_HeadC.rz"} 11.01214119;} if (`objExists ($rigName[0]+ "_HeadC")`) {setAttr {$rigName[0]+ "_HeadC.sx"} 1;} if (`objExists ($rigName[0]+ "_HeadC")`) {setAttr {$rigName[0]+ "_HeadC.sy"} 1;} if (`objExists ($rigName[0]+ "_HeadC")`) {setAttr {$rigName[0]+ "_HeadC.sz"} 1;} if (`objExists ($rigName[0]+ "_JawC")`) {setAttr {$rigName[0]+ "_JawC.tx"} 0;} if (`objExists ($rigName[0]+ "_JawC")`) {setAttr {$rigName[0]+ "_JawC.ty"} 0;} if (`objExists ($rigName[0]+ "_JawC")`) {setAttr {$rigName[0]+ "_JawC.tz"} 0;} if (`objExists ($rigName[0]+ "_JawC")`) {setAttr {$rigName[0]+ "_JawC.rx"} 13.45187185;} if (`objExists ($rigName[0]+ "_JawC")`) {setAttr {$rigName[0]+ "_JawC.ry"} -13.11859863;} if (`objExists ($rigName[0]+ "_JawC")`) {setAttr {$rigName[0]+ "_JawC.rz"} -7.875023463;} ... and so on. Can you check to see if yours is similar? That will hopefully help narrow down what the problem might be. Thanks! Dustin
  • Replyindent
    K Y

    K Y said almost 12 years ago:

    Hi Dustin, Thanks for your help! Seems like I finally located the problem. If I generate a rig with a character name that contains underscores, this will not allow for the saving pose function at Rapid Poser level (it only saves main control attributes. ) Loading pose works fine for the underscored characters with previously saved poses (by characters without underscores.) Is this somehow possible?? Anyways, if I use names without underscores it perfectly works fine so there will be no more troubles, thanks for your amazing scripts it really saves my time!!
  • Dustin Nelson

    Dustin Nelson said almost 12 years ago:

    Ah that makes a lot of sense, the script looks for underscores and breaks up the name based on that. I think for now, I am going to set it up so that rig names can't have underscores, at least for the time being. I will then start trying to make it work so that underscores can be used in a rig name. For now, is it a big deal for you to have to name your characters without underscores? I know that naming conventions are really important, so I hope this won't mess with your workflow. Thanks for diagnosing the problem for me! It's greatly appreciated! Dustin
  • Replyindent
    K Y

    K Y said over 11 years ago:

    Sounds great, thanks for sharing the scripts and please keep up the great works!!

Post a reply: