Adverti horiz upsell

Substance Painter to Arnold 6 1.1.0 for Maya (maya script)

Plug in textures exported from Substance Painter into Maya Arnold 6

License
Button download
3,692 Downloads

Compatibility

  • 2019, 2018, 2017

Operating Systems

  • Windows

History

Created:09/04/2017
Last Modified:07/31/2020
File Size: 49.7 KB

Q/A

Maya 2018 Issue

Date:09/08/2017
Submitted by: triggerhippie triggerhippie
Hi,
I'm trying to use this script at Maya 2018 however i'm not getting any connection/result. I checked step by step with your tutorial but i think i missed a step.
I think I'm having a naming convention error
This show up in my script editor:

"Cannot find aiStandardSurface1SG in Baykok_Baykok_head_Diffuse.png
Cannot find aiStandardSurface1SG in Baykok_Baykok_head_Diffuse.tx
Cannot find aiStandardSurface1SG in Baykok_Baykok_head_Height.png
Cannot find aiStandardSurface1SG in Baykok_Baykok_head_Metalness.png
Cannot find aiStandardSurface1SG in Baykok_Baykok_head_Metalness.tx
Cannot find aiStandardSurface1SG in Baykok_Baykok_head_Normal.png
Cannot find aiStandardSurface1SG in Baykok_Baykok_head_Normal.tx
Cannot find aiStandardSurface1SG in Baykok_Baykok_head_Roughness.png
Cannot find aiStandardSurface1SG in Baykok_Baykok_head_Roughness.tx"

 

Any solutions ?

Replies to this question:

  • teddude75

    teddude75 said almost 7 years ago:

    Your texture doesn't include the "aiStandardSurface1SG".  You need to keep the texture set the same as the shader group in Maya. If your export object is object1 and has a shader group named Object1SG ( include the SG) than make sure that the texture set in Substance Painter is  the same. 
  • jarud

    jarud said almost 7 years ago:

    I also have some problem.
    I did notice that I had to select only the diffuse channel first and the hit the create materials button,
    then deselect the diffuse channel and select the other channels and then push create materials button again to get all the channels correctly hooked up.
     
    -jan erik
  • thedangoldstein

    thedangoldstein said over 6 years ago:

    I'm also having this problem. Just downloaded the latest script today 1/8/18 and am using it with maya 2018.2 and substance painter 2017.4.1.
     
    I also noticed that when hitting the Create Materials button it just completely deletes the geometry no matter what i try. I can undo to get it back, but still keeps deleting it, cant get the textures to connect.
     
    If you could make a new tutorial video of the latest script version for arnold 5 and substance painter 2017 including script installation and texturing linking demo that would be great. Thanks!
  • Replyindent
    teddude75

    teddude75 said over 6 years ago:

     
  • steve karate

    steve karate said over 6 years ago:

    -  you cannot have any spaces or “_” in your names (material names, object names, scene names).  The script uses underscores to separate each item.
     
     
    - as for the problem with geo disappearin, you’re selecting your geo when you run the script....you need to select you material/shader that’s assigned to that geo instead, and then run the script.

Post a reply: